AWS outage impact on backups

Incident Report for Cohesity Helios

Resolved

AWS has reported that most of its services have recovered at this time. We have also communicated with our impacted customers due to this outage through emails and support bot cases. Our current metrics indicate that all backups are functioning normally. We are closing this incident at this time. If you have any questions, please contact Cohesity Support.
Posted Oct 20, 2025 - 22:43 UTC

Investigating

We want to let our customers know that some of the backup runs have been impacted due to the AWS outage. We are closely looking at the issue and will be sending communication to our customers on the impacted runs.
Posted Oct 20, 2025 - 14:32 UTC
This incident affected: Data Protect delivered as a Service.