Data Processing Delays - Activity Page and Reports Affected

Incident Report for Cohesity Helios

Resolved

The Activity Page and Reports on the Helios platform should be fully functional with no lag now.
Posted Aug 25, 2026 - 15:39 UTC

Monitoring

We have deployed a fix, and the sync is expected to complete within the next six hours. We will keep you updated on the progress.
Posted Aug 25, 2026 - 10:51 UTC

Investigating

The Activity Page and Reports on the Helios platform may show delayed or stale information due to an unplanned background sync issue. Our team has identified the cause and is actively working to resolve it. We'll post an update once syncing is back to normal — thanks for your patience!
Posted Aug 24, 2026 - 17:16 UTC
This incident affected: Cohesity Cloud Services Portal.