We would like to inform our customers that Microsoft has confirmed the issue is resolved, and we are closely monitoring our metrics. We will continue to provide updates.
Posted Jul 25, 2025 - 06:09 UTC
Update
We are continuing to work on this issue and escalating it to Microsoft. We will provide more updates as we hear from Microsoft. We are also working to see if we can mitigate this issue from our end. We apologize for any inconvenience.
Posted Jul 20, 2025 - 04:03 UTC
Update
We are continuing to investigate this issue.
Posted Jul 20, 2025 - 03:06 UTC
Update
We are continuing to investigate this issue.
Posted Jul 19, 2025 - 19:07 UTC
Investigating
We want to inform our customers that Teams backups are experiencing intermittent failures due to a change on the Microsoft end. We are working internally to come up with a workaround while Microsoft addresses the core issue. We apologize for any inconvenience. We will continue to provide updates on the progress.
Posted Jul 19, 2025 - 18:01 UTC
This incident affected: Data Protect delivered as a Service.